<!DOCTYPE html>
<html class="no-js">
<head>
	<meta http-equiv="content-type" content="text/html; charset=utf-8"/>	<meta name="theme-color" content="#0078a9"/>	<meta name="viewport" content="width=device-width, initial-scale=1">	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"/>	<script language="javascript" type="text/javascript" src="/includes/WFP_cookies.js"></script>
	<script type='text/javascript'>		   ( function() {
			var is_from_eu =cookiejar.fetch('is_from_eu');
			var subscription_type=cookiejar.fetch('fpnp__subscription_type');
			var is_subscribe_path = false;
			var is_cxense_bot = false;
			 if(navigator.userAgent.indexOf('cXensebot') > -1){
				is_cxense_bot = true;
			  }
				   if(document.location.pathname.indexOf("/subscribe") > -1){
						   is_subscribe_path = true;
				   }
					if((typeof(is_from_eu) =='undefined' || is_from_eu == null  || is_from_eu == false ||  is_from_eu == 'yes') && (!is_subscribe_path) && (!is_cxense_bot)){
							if(subscription_type && subscription_type !== 'read-now-pay-later'){
								   // do not check if user is subscriber or trial user
							   }else{
								   try{
											 var loadGeoScriptAsync = function(uri){
												   return new Promise((resolve, reject) => {
												  var tag = document.createElement('script');
												  tag.src = uri;
												  tag.type='text/javascript';
												  tag.onload = () => {
													resolve();
												  };
											  var firstScriptTag= document.getElementsByTagName('script')[0];
											  firstScriptTag.parentNode.insertBefore(tag, firstScriptTag);
											 });
											  }
										   var scriptLoaded = loadGeoScriptAsync('https://ssl.geoplugin.net/extras/cookielaw.js?k=67ff89604d31f4c1');
										   scriptLoaded.then(function(){
												   var result = geop1ugin_cookieConsent();  
												   if(typeof(result) !== "undefined"){
													   if(result){
															 window.location.href='/gdpr';
													   }else{
															  cookiejar.bake('is_from_eu','no',3650,'/',document.domain);
													   }
													}
											});
									}
									catch(err){
											 console.log("Error occurred on GeoPlugin");
									}
						   }

					}
			} )();
	</script> 
																																																																																																																																					<script type="text/javascript"> var googletag=googletag||{};googletag.cmd=googletag.cmd||[];(function(){var a=document.getElementsByTagName('script')[0],b=document.createElement("script");b.async=true;b.src="https://www.googletagservices.com/tag/js/gpt.js";b.type='text/javascript';a.parentNode.insertBefore(b,a)}()); </script>
							<script async src="//js-sec.indexww.com/ht/p/185517-159829111959756.js"></script>			<script type='text/javascript'>				var gptadunit = "/3823844/winnipegfreepress.com";
				var mobileadunit = "/3823844/m.winnipegfreepress.com";
			</script>
				<meta name="verify-v1" content="lzarxQ0dLetbrZM+htnHzoOylY1jBOWlVX9yx7oyG4c=" />											<style type="text/css" title="style_pluck_comments">.pmobile-comments-vote-down{display: none;}.pmobile-comments-vote-up{display: none;}.pluck-comm-rate-controls{display: none;}.loggedout{display: none;}.loggedin{display: none;}.isSbscrbr{display: none;}.isNotSbscrbr{display: none;}.pmobile-comments-submit-wrap{display: none;}.pmobile-comments-comment-reply{display:none;}.pmobile-comments-comment{display:none;}.pluck-comm-input-content{display: none;}.pluck-comm-reply-button{display: none;}.pluck-login-comment-input{display: none;}.pmobile-auth-wrap{display: none;}</style>
		<style type="text/css" title="conditionals">.account-state-element.trial { display: none; }.account-state-element.pay-as-you-go { display: none; }.account-state-element.not-logged { display: none; }.account-state-element.subscriber { display: none; }</style>
											
<!-- article image objects count  2 -->
<!-- article image objects count after topPhoto 1 -->
<!-- are we jumbo $jumbo -->
<meta name="publish-date" content="2019-08-01 03:00:00 CDT" />
<meta name="cXenseParse:taxonomy" content="sports" /><meta name="cXenseParse:recs:category" content="sports" /><meta name="cXenseParse:taxonomy" content="sports/football/bombers" /><meta name="cXenseParse:recs:category" content="sports/football/bombers" /><meta name="cXenseParse:recs:description" content="TORONTO &mdash; Argos quarterback McLeod Bethel-Thompson has suited up with 13 organizations in nine years as a pro. | In short, he has some experience with the trials and tribulations of a life in football. But he insists he won&rsquo;t let Toronto&rsquo;s 0-6 start crush his enthusiasm for the game. | &ldquo;If we were just a bad team, it would be just a bad team,&rdquo; Bethel-Thompson said Wednesday morning at BMO Field. &ldquo;But we&rsquo;re a good team that&rsquo;s performing badly. And you sound like a broken record, and you get sick talking about it over and over again, and now seeing the results. | &ldquo;The losing part was the hard part, but the chemistry&rsquo;s fantastic. We have everything in this locker room and everything on this team except wins. Coach (Corey) Chamblin has been leading us like nobody could, especially at this time. When it comes, this will be a better story for you guys to write.&rdquo;" /><meta name="cXenseParse:recs:publishtime" content="2019-08-01T08:00:00.000Z" /><meta name="cXenseParse:recs:wfp-updatedtime" content="2019-08-01T08:00:00.000Z" /><meta name="cXenseParse:recs:wfp-subtitle" content="'...The chemistry is fantastic,' even after 0-6 start, pivot says" /><meta name="cXenseParse:recs:articleid" content="513478282"/><meta name="cXenseParse:recs:image" content="normal"/><meta name="cXenseParse:wfp-sourceimage" content="wfp-circle"/><meta name="cXenseParse:wfp-contenttargetpath" content="/sports/football/bombers"/><meta name="cXenseParse:wfp-contentcategory" content="Bomber Report"/><meta name="cXenseParse:wfp-mediacommentscost" content="bombers|comments|27"/><meta name="cXenseParse:wfp-contenttypename" content="WFP Story"/><meta name="cXenseParse:recs:custom0" content="wfp-circle"/><meta name="cXenseParse:recs:custom1" content="/sports/football/bombers"/><meta name="cXenseParse:recs:custom2" content="Bomber Report"/><meta name="cXenseParse:recs:custom3" content="bombers|comments|27"/><meta name="cXenseParse:recs:custom4" content="WFP Story"/><meta name="cXenseParse:recs:wordcount" content="599"/><meta property="article:modified_time" content="2019-08-01T08:00:00.000Z" /><meta property="cXenseParse:author" content="Mike Sawatzky"/>
<meta property="og:article:author" content="Mike Sawatzky"/><meta name="bt:modDate" content="2019-08-01T03:00:00-0500" /><meta property="bt:type" content="article" /><meta name="cXenseParse:recs:wfp-imagecaption" content="JOHN WOODS / THE CANADIAN PRESS FILES</p><p>Despite his team&rsquo;s 0-6 start to the season, Argos QB McLeod Bethel-Thompson feels he&rsquo;s leading a good team that needs to play to its potential.</p>"/><meta property="og:image" content="https://media.winnipegfreepress.com/images/648*432/NEP6253373.jpg"/><meta property="fb:page_id" content="68559611193" />

														<meta property="og:title" content="Argonauts QB remains upbeat" />
						<meta property="og:description" content="TORONTO &mdash; Argos quarterback McLeod Bethel-Thompson has suited up with 13 organizations in nine years as a pro.
In short, he has some experience with the trials and tribulations of a life in football." />
																																																																																																																																														<meta property="twitter:card" content="summary_large_image" />
				<meta property="twitter:image" content="https://media.winnipegfreepress.com/images/648*432/NEP6253373.jpg" />
															<meta property="twitter:site" content="@WinnipegNews" />
					<meta name="twitter:domain" content="winnipegfreepress.com">
																			<meta property="twitter:title" content="Argonauts QB remains upbeat" />
										<meta property="twitter:description" content="TORONTO &mdash; Argos quarterback McLeod Bethel-Thompson has suited up with 13 organizations in nine years as a pro.
In short, he has some experience with the trials and tribulations of a life in football." />
			<meta property="twitter:url" content="https://www.winnipegfreepress.com/sports/football/bombers/argonauts-qb-remains-upbeat-513478282.html" />
				<link rel="canonical" href="https://www.winnipegfreepress.com/sports/football/bombers/argonauts-qb-remains-upbeat-513478282.html" />
								<title>Argonauts QB remains upbeat - Winnipeg Free Press</title>
		<meta name="description" content="TORONTO &mdash; Argos quarterback McLeod Bethel-Thompson has suited up with 13 organizations in nine..." />
			<meta name="keywords" content="sports, bomber report, football" />
																<script type="application/ld+json">
	{
	  "@context": "https://schema.org",
	  "@type": "NewsArticle",
	  "mainEntityOfPage": {
		"@type": "WebPage",
		"@id": "https://www.winnipegfreepress.com/sports/football/bombers/argonauts-qb-remains-upbeat-513478282.html"
	  },
		  "headline": "Argonauts QB remains upbeat",
		  "image": [
		"https://media.winnipegfreepress.com/images/648*432/NEP6253373.jpg"
	   ],
	  "datePublished": "2019-08-01T03:00:00-0500",
	  "dateModified": "2019-08-01T03:00:00-0500",
		  "author": {
		"@type": "Person",
		"name": "Mike Sawatzky"
	  },
		   "publisher": {
		"@type": "Organization",
						"name": "Winnipeg Free Press",
			"logo": {
			  "@type": "ImageObject",
			  "url": "https://media.winnipegfreepress.com/designimages/winnipegfreepress-logo.png"
			}
				  },
	  "description": "TORONTO &mdash; Argos quarterback McLeod Bethel-Thompson has suited up with 13 organizations in nine years as a pro.
In short, he has some experience with the trials and tribulations of a life in football."
	  	  ,"isAccessibleForFree": "False",
	  "hasPart":
		{
		"@type": "WebPageElement",
		"isAccessibleForFree": "False",
		"cssSelector" : ".paidaccess"
		}
	  	}
	</script>
												<link type="text/css" rel="stylesheet" href="https://www.winnipegfreepress.com/includes/ec1f958f20ed412551b59cd9924c5742/v4_enhancement_lib.css"/>										<link type="text/css" rel="stylesheet" href="https://www.winnipegfreepress.com/includes/af5d9d5849d67279f41de24f80776abf/v6_base.css"/>							<link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.3.1/css/all.css" integrity="sha384-mzrmE5qonljUremFsqc01SB46JvROS7bZs3IO2EmfFsd15uHvIt+Y8vEf7N7fWAU" crossorigin="anonymous">
	<script src="https://use.fontawesome.com/0c21a0b8c1.js"></script>
								<meta name="apple-itunes-app" content="app-id=1202914748">
				<link rel="shortcut icon" href="//media.winnipegfreepress.com/designimages/favicon.ico" type="image/x-icon" />			<link rel="apple-touch-icon-precomposed" sizes="57x57" href="//media.winnipegfreepress.com/designimages/apple-icon-57x57.png" />
			<link rel="apple-touch-icon-precomposed" sizes="114x114" href="//media.winnipegfreepress.com/designimages/apple-icon-114x114.png" />
			<link rel="apple-touch-icon-precomposed" sizes="72x72" href="//media.winnipegfreepress.com/designimages/apple-icon-72x72.png" />
			<link rel="apple-touch-icon-precomposed" sizes="144x144" href="//media.winnipegfreepress.com/designimages/apple-icon-144x144.png" />
			<link rel="apple-touch-icon-precomposed" sizes="60x60" href="//media.winnipegfreepress.com/designimages/apple-icon-60x60.png" />
			<link rel="apple-touch-icon-precomposed" sizes="120x120" href="//media.winnipegfreepress.com/designimages/apple-icon-120x120.png" />
			<link rel="apple-touch-icon-precomposed" sizes="76x76" href="//media.winnipegfreepress.com/designimages/apple-icon-76x76.png" />
			<link rel="apple-touch-icon-precomposed" sizes="152x152" href="//media.winnipegfreepress.com/designimages/apple-icon-152x152.png" />
			<link rel="apple-touch-icon-precomposed" sizes="180x180" href="//media.winnipegfreepress.com/designimages/apple-icon-180x180.png" />
			<link rel="icon" type="image/png" href="//media.winnipegfreepress.com/designimages/android-icon-192x192.png" sizes="192x192" />
			<link rel="icon" type="image/png" href="//media.winnipegfreepress.com/designimages/android-icon-144x144.png" sizes="144x144" />
			<link rel="icon" type="image/png" href="//media.winnipegfreepress.com/designimages/android-icon-72x72.png" sizes="72x72" />
			<link rel="icon" type="image/png" href="//media.winnipegfreepress.com/designimages/android-icon-48x48.png" sizes="48x48" />
			<link rel="icon" type="image/png" href="//media.winnipegfreepress.com/designimages/android-icon-36x36.png" sizes="36x36" />
			<link rel="icon" type="image/png" href="//media.winnipegfreepress.com/designimages/favicon-96x96.png" sizes="96x96" />
			<link rel="icon" type="image/png" href="//media.winnipegfreepress.com/designimages/favicon-32x32.png" sizes="32x32" />
			<link rel="icon" type="image/png" href="//media.winnipegfreepress.com/designimages/favicon-16x16.png" sizes="16x16" />
			<link rel="icon" type="image/png" href="//media.winnipegfreepress.com/designimages/favicon-128.png" sizes="128x128" />
			<meta name="msapplication-TileColor" content="#FFFFFF" />
			<meta name="msapplication-TileImage" content="//media.winnipegfreepress.com/designimages/mstile-144x144.png" />
			<meta name="msapplication-square70x70logo" content="//media.winnipegfreepress.com/designimages/mstile-70x70.png" />
			<meta name="msapplication-square150x150logo" content="//media.winnipegfreepress.com/designimages/mstile-150x150.png" />
			<meta name="msapplication-square310x310logo" content="//media.winnipegfreepress.com/designimages/mstile-310x310.png" />
		<meta name="application-name" content="Winnipeg Free Press"/>
			<script type="text/javascript" src="https://www.winnipegfreepress.com/includes/860c956c3b2f23db232417efc7cc8c34/cryptoJS.js"></script>
	
	<script>
		var allTheCookie = document.cookie;
		var v4UserClientId = decodeURIComponent(allTheCookie.replace(/(?:(?:^|.*;\s*)v4_clientuserid\s*\=\s*([^;]*).*$)|^.*$/, "$1"));
		  var v4UserClientIdHash = "";
		  if (v4UserClientId.length > 0) {
			v4UserClientIdHash = '' + CryptoJS.MD5(v4UserClientId);
		  }

	  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
	  ga('create', 'UA-350959-63', 'auto'); 
	  		  			ga('set', 'dimension3', 'Mike Sawatzky');
		  	  	  		ga('set', 'dimension4', '599');
	  		var subscription_type=cookiejar.fetch('fpnp__subscription_type');
		 if(subscription_type){
		ga('set', 'dimension2', subscription_type);
	  } else {
		ga('set', 'dimension2', 'not-logged-in');
	  }
		var whitelist_group=cookiejar.fetch('fpnp__whitelist_group');
		 if(whitelist_group){
		ga('set', 'dimension7', 'whitelist_' + whitelist_group);
	  } 

	  	  if(v4UserClientIdHash != ""){
		ga('set', '&uid', v4UserClientIdHash);
	  }
	  ga('send', 'pageview');
	</script>
				<!-- Google Tag Manager -->
		<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
		new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
		j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
		'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
		})(window,document,'script','dataLayer','GTM-TK48WJ9');</script>
		<!-- End Google Tag Manager -->
		<script src="https://cdn.boomtrain.com/analyticstrain/ae6897195848feb20f96c5beac08e41b/analyticstrain.min.js"></script>
					</head>
<body class="">
			<!-- Google Tag Manager (noscript) -->
		<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-TK48WJ9"
		height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
		<!-- End Google Tag Manager (noscript) -->
		<script src="https://www.winnipegfreepress.com/includes/1aaf5915470b33c3c7fc41701fd13083/jquery.min.js"></script>
								<script type="text/javascript" >var js="0.0";</script><script type="text/javascript1.0" >js="1.0";</script><script type="text/javascript1.1">js="1.1";</script><script type="text/javascript1.2" >js="1.2";</script><script type="text/javascript1.3">js="1.3";</script><script type="text/javascript1.4" >js="1.4";</script><script type="text/javascript1.5">js="1.5";</script><script type="text/javascript1.6">js="1.6";</script><script type="text/javascript1.7">js="1.7";</script><script type="text/javascript1.8">js="1.8";</script><script type="text/javascript1.9">js="1.9";</script><script type="text/javascript"> 
/* <![CDATA[ */
var bb=new Image();var _ti=910;var _q="";var na=(navigator.appName=="Netscape");var ns=(navigator.appName.substring(0,9)=="Microsoft");var _qDate=new Date();var _r=(document.referrer.indexOf(getdomain(location))>-1?"":document.referrer);_q+="&5="+parseInt(_qDate.getTimezoneOffset());_q+="&35="+parseInt(_qDate.toString().indexOf("aylight")>-1?1:0);_q+="&6=513478282";_q+="&7=400744";_q+="&8="+encodeURIComponent(document.location);_q+="&9="+encodeURIComponent(_r);_q+="&10="+encodeURIComponent(document.title);_q+="&11="+encodeURIComponent(navigator.userAgent);_q+="&12="+encodeURIComponent((na?navigator.language:navigator.userLanguage));_q+="&13="+((navigator.javaEnabled()?'1':'0'));_q+="&14="+encodeURIComponent(js);if(document.cookie.indexOf("cc")==-1)document.cookie="cc=t;";_q+="&15="+((document.cookie.indexOf("cc")==-1)?"0":"1");_q+="&16="+encodeURIComponent((screen.width+'x'+screen.height));_q+="&17="+encodeURIComponent(((ns)?screen.colorDepth:screen.pixelDepth));_q+="&18="+encodeURIComponent(Math.random());_q+="&19="+_ti;bb.src="https://s.clickability.com/s?"+_q;
function getdomain(a){var i=a.host.indexOf(":");return (i>=0)?a.host.substring(0,i):a.host;}if(self['setupalready']){var dosetup = false;alert('There are two $imware.tracker calls on this page. Please alert Client Services');}else{var dosetup = true;var hasonload=false;}/* ]]> */
</script><noscript>
<img width="1" height="1" src="https://s.clickability.com/s?19=990&14=0&6=513478282&7=400744&25=0&18=0.7294455457127149">
</noscript>
																																																																																																											<div class="slide-menu notranslate" id="slide-menu">
		<h3>August 2, 2019 <a href="#" id="nav-close-btn" class="fr"><i class="fa fa-times"></i></a></h3>
		<div class="weather">
			<img src="//media.winnipegfreepress.com/designimages/weather-icon-h.jpg" alt=""/>
			<p class="info">Winnipeg</br>
			<span class="bold">28&deg; C</span>, A few clouds</p>
			<p class="full"><a href="/weather/">Full Forecast</a></p>
		</div>
		<div class="header-links">
							<div class="loggedin">
					<a href="/contact-us/">Contact Us</a>
					<a href="/subscribe/" class="subscribe account-state-element not-logged trial pay-as-you-go">Subscribe</a>
					<a href="/customer-service/" class="subscribe account-state-element subscriber">Manage Subscription</a>
					<a href="/insider/">Insider</a>
				</div>
				<div class="loggedout">
					<a class="type-login requires-account-server" href="https://fpnewsplatform.winnipegfreepress.com/login">Log in</a>
					<a class="type-register subscribe requires-account-server" href="https://fpnewsplatform.winnipegfreepress.com/register">Create Free Account</a>
					<a class="type-help" href="/help/">Help</a>
				</div>
				<ul>
					<li><a class="slide-menu-section" href="javascript:void(0);"><i class="fa fa-envelope contact-icon"></i></a>
						<ul class="slide-menu-inner">
							<li><a href="/contact-us/">Contact Us</a></li>
							<li><a href="/newstips/">Submit a News Tip</a></li>
							<li><a href="/mediakit/#contact-info">Advertising Contact</a></li>
													</ul>
					</li>
					<li><a class="slide-menu-section" href="javascript:void(0);"><i class="fa fa-cog settings-icon"></i></a>
						<ul class="slide-menu-inner">
							<div class="loader"><p><img src="//media.winnipegfreepress.com/designimages/jq-lightbox-ico-loading.gif"><br>Finding your<br>information</p></div>
							<div class="loggedin">
								<li><a class="type-profile" href="https://fpnewsplatform.winnipegfreepress.com/account">My Account</a></li>
								<li><a href="/customer-service/">Manage my Subscription</a></li>
								<li><a class="type-change-password">Change Password</a></li>
								<li><hr /></li>
								<li><a class="view-type-anchor grid-view" href="javascript:">Grid View</a></li>
								<li><a class="view-type-anchor list-view" href="javascript:">List View</a></li>
								<li><a class="view-type-anchor compact-view" href="javascript:">Compact View</a></li>
								<li><a class="text-size-anchor" href="javascript:">Text Size</a></li>
								<li><a class="translate-anchor" href="javascript:">Translate</a></li>
								<li><hr /></li>
								<li><a class="type-logout" href="https://fpnewsplatform.winnipegfreepress.com/logout">Log Out</a></li>
							</div>
							<div class="loggedout">
								<li class="requires-account-server"><a class="type-login" href="https://fpnewsplatform.winnipegfreepress.com/login">Log in</a></li>
								<li class="requires-account-server"><a class="type-register" href="https://fpnewsplatform.winnipegfreepress.com/register">Create Free Account</a></li>
								<li><a class="type-help" href="/help/">Help</a></li>
								<li><hr /></li>
								<li><a class="view-type-anchor grid-view" href="javascript:">Grid View</a></li>
								<li><a class="view-type-anchor list-view" href="javascript:">List View</a></li>
								<li><a class="view-type-anchor compact-view" href="javascript:">Compact View</a></li>
								<li><a class="text-size-anchor" href="javascript:">Text Size</a></li>
								<li><a class="translate-anchor" href="javascript:">Translate</a></li>
							</div>
						</ul>
					</li>
					<li><a class="type-help" href="/help/"><i class="fa fa-question"></i></a></li>
				</ul>
					</div>
									<ul>
					<li><a class="slide-menu-section" href="javascript:void(0);">Replica E-Edition <i class="fa fa-plus"></i></a>
						<ul class="slide-menu-inner">
							<li><a href="//www.winnipegfreepress.com/e-edition/">About the E-Edition <small style="color: #a80711; font-size: .7em; margin-left: 5px;">NEW</small></a></li>
							<li><a href="http://ee.winnipegfreepress.com/" target="_blank">Winnipeg Free Press</a></li>
							<li><a href="http://winnipeg.can.newsmemory.com/?special=The+Herald">The Herald</a></li>
							<li><a href="http://winnipeg.can.newsmemory.com/?special=The+Headliner">The Headliner</a></li>
							<li><a href="http://winnipeg.can.newsmemory.com/?special=The+Lance">The Lance</a></li>
							<li><a href="http://winnipeg.can.newsmemory.com/?special=The+Metro">The Metro</a></li>
							<li><a href="http://winnipeg.can.newsmemory.com/?special=The+Souwester">The Sou'Wester</a></li>
							<li><a href="http://winnipeg.can.newsmemory.com/?special=The+Times">The Times</a></li>
						</ul>
					</li>
					<li><a href="//www.winnipegfreepress.com/edition/above-the-fold/">Above the Fold</a></li>
					<li><h5>Sections</h5></li>
					<li><a href="//www.winnipegfreepress.com/">Home</a></li>
					<li><a href="//www.winnipegfreepress.com/local/">Local</a></li>
										<li><a href="//www.winnipegfreepress.com/canada/">Canada</a></li>
					<li><a href="//www.winnipegfreepress.com/world/">World</a></li>
					<li><a class="slide-menu-section" href="javascript:void(0);">Arts &amp; Life <i class="fa fa-plus"></i></a>
						<ul class="slide-menu-inner">
							<li><a href="//www.winnipegfreepress.com/arts-and-life/">All Arts &amp; Life</a></li>
							<li><a href="//www.winnipegfreepress.com/arts-and-life/entertainment/arts/">The Arts</a></li>
							<li><a href="//www.winnipegfreepress.com/arts-and-life/entertainment/books/">Books</a></li>
							<li><a href="//www.winnipegfreepress.com/arts-and-life/entertainment/celebrities/">Celebrities</a></li>
							<li><a href="//www.winnipegfreepress.com/arts-and-life/diversions/">Diversions</a></li>
							<li><a href="//www.winnipegfreepress.com/arts-and-life/diversions/puzzles">Puzzles</a></li>
							<li><a href="//www.winnipegfreepress.com/arts-and-life/life/greenpage/">The Green Page</a></li>
							<li><a href="//www.winnipegfreepress.com/arts-and-life/events/">Events</a></li>
							<li><a href="//www.winnipegfreepress.com/arts-and-life/life/faith/">Faith</a></li>
							<li><a href="//www.winnipegfreepress.com/arts-and-life/food/">Food &amp; Drink</a></li>
							<li><a href="//www.winnipegfreepress.com/arts-and-life/life/health/">Your Health</a></li>
							<li><a href="//www.winnipegfreepress.com/arts-and-life/life/">Life &amp; Style</a></li>
							<li><a href="//www.winnipegfreepress.com/arts-and-life/entertainment/movies/">Movies</a></li>
							<li><a href="//www.winnipegfreepress.com/arts-and-life/entertainment/music/">Music</a></li>
							<li><a href="//www.winnipegfreepress.com/arts-and-life/life/sci_tech/">Science &amp; Technology</a></li>
							<li><a href="//www.winnipegfreepress.com/arts-and-life/entertainment/TV/">TV</a></li>
							<li><a href="//www.winnipegfreepress.com/travel/">Travel</a></li>
						</ul>        
					</li>
										<li><a class="slide-menu-section" href="javascript:void(0);">Business <i class="fa fa-plus"></i></a>
						<ul class="slide-menu-inner">
							<li><a href="//www.winnipegfreepress.com/business/">All Business</a></li>
							<li><a href="//www.winnipegfreepress.com/business/agriculture/">Agriculture</a></li>
														<li><a href="//www.winnipegfreepress.com/business/finance/">Personal Finance</a></li>
						</ul>
					</li>
					<li><a class="slide-menu-section" href="javascript:void(0);">Sports <i class="fa fa-plus"></i></a>
						<ul class="slide-menu-inner">
							<li><a href="//www.winnipegfreepress.com/sports/">All Sports</a></li>
							<li><a href="//www.winnipegfreepress.com/sports/amateur/">Amateur</a></li>
							<li><a href="//www.winnipegfreepress.com/sports/autoracing/">Auto Racing</a></li>
							<li><a href="//www.winnipegfreepress.com/sports/football/bombers/">Blue Bombers</a></li>
							<li><a href="//www.winnipegfreepress.com/sports/curling/">Curling</a></li>
							<li><a href="//www.winnipegfreepress.com/sports/football/">Football</a></li>
							<li><a href="//www.winnipegfreepress.com/sports/baseball/goldeyes/">Goldeyes</a></li>
							<li><a href="//www.winnipegfreepress.com/sports/golf/">Golf</a></li>
							<li><a href="//www.winnipegfreepress.com/sports/high-school/">High School</a></li>
							<li><a href="//www.winnipegfreepress.com/sports/hockey/">Hockey</a></li>
							<li><a href="//www.winnipegfreepress.com/sports/horseracing/">Horse Racing</a></li>
							<li><a href="//www.winnipegfreepress.com/sports/hockey/jets/">Winnipeg Jets</a></li>
							<li><a href="//www.winnipegfreepress.com/sports/hockey/manitoba-moose/">Manitoba Moose</a></li>
							<li><a href="//www.winnipegfreepress.com/sports/baseball/">MLB</a></li>
							<li><a href="//www.winnipegfreepress.com/sports/basketball/">NBA</a></li>
							<li><a href="//www.winnipegfreepress.com/sports/olympics/">Olympics</a></li>
							<li><a href="//www.winnipegfreepress.com/sports/soccer/">Soccer</a></li>
						</ul>
					</li>
					<li><a href="//www.winnipegfreepress.com/arts-and-life/life/faith/">Faith</a></li>

					<li><a href="//www.theleafnews.com/" target="_blank">The Leaf - Cannabis News</a></li>
					<li><a class="slide-menu-section" href="javasctip:void(0);">Opinion <i class="fa fa-plus"></i></a>
						<ul class="slide-menu-inner">
							<li><a href="//www.winnipegfreepress.com/opinion/">All Opinion</a></li>
							<li><a href="//www.winnipegfreepress.com/opinion/analysis/">Analysis</a></li>
							<li><a href="//www.winnipegfreepress.com/opinion/columnists/">Columnists</a></li>
							<li><a href="//www.winnipegfreepress.com/opinion/editorials/">Editorials</a></li>
							<li><a href="//www.winnipegfreepress.com/opinion/editorial-cartoon/">Editorial Cartoons</a></li>
							<li><a href="//www.winnipegfreepress.com/opinion/letters_to_the_editor/">Letters to the Editor</a></li>
							<li><a href="//www.winnipegfreepress.com/opinion/send_a_letter/">Send a Letter to the Editor</a></li>
						</ul>
					</li>
					<li><a class="slide-menu-section" href="javascript:void(0);">Media <i class="fa fa-plus"></i></a>
						<ul class="slide-menu-inner">
							<li><a href="//www.winnipegfreepress.com/multimedia/">All Media</a></li>
							<li><a href="//www.winnipegfreepress.com/multimedia/fp-slideshow/">Photo Galleries</a></li>
							<li><a href="//www.winnipegfreepress.com/multimedia/video/">Videos</a></li>
						</ul>
					</li>
					<li><a href="//www.winnipegfreepress.com/special/">Special Coverage</a></li>
					<li><a class="slide-menu-section" href="javasctip:void(0);">Canstar Community News <i class="fa fa-plus"></i></a>
						<ul class="slide-menu-inner">
							<li><a href="//www.winnipegfreepress.com/our-communities/">All Canstar Community News</a></li>
							<li><a href="//www.winnipegfreepress.com/our-communities/headliner/">The Headliner</a></li>
							<li><a href="//www.winnipegfreepress.com/our-communities/herald/">The Herald</a></li>
							<li><a href="//www.winnipegfreepress.com/our-communities/lance/">The Lance</a></li>
							<li><a href="//www.winnipegfreepress.com/our-communities/metro/">The Metro</a></li>
							<li><a href="//www.winnipegfreepress.com/our-communities/souwester/">The Sou'wester</a></li>
							<li><a href="//www.winnipegfreepress.com/our-communities/times/">The Times</a></li>
							<li><a href="//www.winnipegfreepress.com/our-communities/sports/">Sports</a></li>
							<li><a href="//www.winnipegfreepress.com/arts-and-life/events/">Events</a></li>
							<li><a href="//www.winnipegfreepress.com/our-communities/contact-us/">Contact Us</a></li>
							<li><a href="//www.winnipegfreepress.com/our-communities/e-editions.html">E-Editions</a></li>
						</ul>
					</li>
					<li><a class="slide-menu-section" href="javasctip:void(0);">Homes <i class="fa fa-plus"></i></a>
						<ul class="slide-menu-inner">
							<li><a href="https://homes.winnipegfreepress.com/winnipeg-real-estate/">Property Listings</a></li>
							<li><a href="https://homes.winnipegfreepress.com/winnipeg-real-estate-news/category-featured/">Featured News</a></li>
							<li><a href="https://homes.winnipegfreepress.com/winnipeg-real-estate-news/category-renovation-design/">Renovation and design</a></li>
							<li><a href="https://homes.winnipegfreepress.com/winnipeg-real-estate-news/category-new-homes/">New homes</a></li>
							<li><a href="https://homes.winnipegfreepress.com/winnipeg-real-estate-news/category-resale-homes/">Resale homes</a></li>
						</ul>
					</li>

					<li><a class="slide-menu-section" href="javasctip:void(0);">Autos <i class="fa fa-plus"></i></a>
						<ul class="slide-menu-inner">
							<li><a href="https://autos.winnipegfreepress.com">All Autos</a></li>
							<li><a href="https://autos.winnipegfreepress.com/cars/salebyowner">Sell Your Car</a></li>
							<li><a href="https://autos.winnipegfreepress.com/cars/search?type=1&make=0&model=0&price=0&dealer=0&odometer=0&year=0&service=0&bodystyle=0&city=0">New Cars For Sale</a></li>
							<li><a href="https://autos.winnipegfreepress.com/cars/search?type=2&make=0&model=0&price=0&dealer=0&odometer=0&year=0&service=0&bodystyle=0&city=0">Used Cars For Sale</a></li>
							<li><a href="https://autos.winnipegfreepress.com/cars/search?type=3&make=0&model=0&price=0&dealer=0&odometer=0&year=0&service=0&bodystyle=0&city=0">Certified Pre-owned vehicles</a></li>
							<li><a href="https://autos.winnipegfreepress.com/news/section/2/autos-articles">Autos Articles</a></li>
							<li><a href="https://autos.winnipegfreepress.com/news/section/1/autos-reviews">Autos Reviews</a></li>
							<li><a href="https://autos.winnipegfreepress.com/news/section/3/backyard-mechanic">Backyard Mechanic</a></li>
							<li><a href="https://autos.winnipegfreepress.com/news/section/5/classic-cruising">Classic Cruising</a></li>
							<li><a href="https://autos.winnipegfreepress.com/news/section/4/willys-garage">Willy's Garage</a></li>
						</ul>
					</li>
					<li><a href="http://marketplace.winnipegfreepress.com">Classifieds</a></li>
					<li><a href="http://flyertown.winnipegfreepress.com?p=wfp&chrome=nohead&locale=en&utm_source=fm&utm_medium=fm_4513&utm_term=title&utm_campaign=wishabi_1_0">Flyers</a></li>
					<li><a href="https://www.winnipegfreepress.com/canada-coupons">Coupons</a></li>
					<li><a href="http://marketplace.winnipegfreepress.com/winnipeg/careers/search">Careers</a></li>
					<li><a href="https://passages.winnipegfreepress.com">Obituaries</a></li>
										<li><a href="http://store.winnipegfreepress.com">Store</a></li>
					<li><a href="http://archives.winnipegfreepress.com/">Archives</a></li>
					<li><a href="//www.winnipegfreepress.com/contests">Contests</a></li>
					<li><a href="//www.winnipegfreepress.com/publications">Publications</a></li>

					<li><a class="slide-menu-section" href="javascript:void(0);"> About Us <i class="fa fa-plus"></i></a>
						<ul class="slide-menu-inner">
							<li><a href="//www.winnipegfreepress.com/about-us/">About Us</a></li>
							<li><a href="//www.winnipegfreepress.com/advertising/">Advertising</a></li>
							<li><a href="//www.winnipegfreepress.com/contact-us/">Contact Us</a></li>
							<li><a href="//www.winnipegfreepress.com/carriers-retailers/">Carrier Positions &amp; Retailer Requests</a></li>
							<li><a href="http://www.fpnewspapers.com/">FP Newspapers Inc.</a></li>
							<li><a href="//www.winnipegfreepress.com/history/">History</a></li>
							<li><a href="//www.winnipegfreepress.com/internships/">Internships</a></li>
							<li><a href="//www.winnipegfreepress.com/job-opportunities/">Job Opportunities</a></li>
							<li><a href="//www.winnipegfreepress.com/cafe">News Café</a></li>
							<li><a href="//www.winnipegfreepress.com/privacy-policy/">Privacy Policy</a></li>
							<li><a href="//www.winnipegfreepress.com/retail-locations/">Retail Locations</a></li>
							<li><a href="//www.winnipegfreepress.com/biographies/">Staff Biographies</a></li>
							<li><a href="//www.winnipegfreepress.com/terms-conditions/">Terms and Conditions</a></li>



						</ul>
					</li>
					<li><a href="//www.winnipegfreepress.com/privacy-policy/">Privacy Policy</a></li>
				</ul>
										<div class="social-icons">
					<a href="http://www.facebook.com/winnipegfreepress" target="_blank" title="Winnipeg Free Press on Facebook"><i class="fa fa-facebook-f"></i></a>
					<a href="http://twitter.com/winnipegnews" target="_blank" title="Winnipeg Free Press on Twitter"><i class="fa fa-twitter"></i></a>
					<a href="http://instagram.com/winnipegfreepress/" target="_blank" title="Winnipeg Free Press on Instagram"><i class="fa fa-instagram"></i></a>
				</div>
							<p class="copyright">&copy;2019 FP Newspaper Inc.</p>
	</div>
			<div id="google_translate_element" style="display:none;"></div><script type="text/javascript">
		function googleTranslateElementInit() {
			new google.translate.TranslateElement({pageLanguage: 'en', layout: google.translate.TranslateElement.InlineLayout.HORIZONTAL, gaTrack: true, gaId: 'UA-350959-63'}, 'google_translate_element');
		}
		</script><script type="text/javascript" src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit"></script>
			<div class="container" id="inner-wrap">
				<div class="top new">
											<div class="fixed top" id="fixed-header">
															<div class="top-ad-box">
									<div class="top-ad">
										<div id="leaderboard" class="ad-leaderboard"></div>
									</div>

								</div>
																					<header>
								<div class="header-top">
									<div class="header-content">

	<a href="Javascript: void(0);" id="nav-open-btn2" class="nav-btn-mobile"><i class="fas fa-bars"></i></a>
	<a class="header-logo" href="/">									
		<img src="//media.winnipegfreepress.com/binary/freepress_white.svg" alt="" />			
	</a> 
	<a href="#" class="account-state-element trial balance info-bubble" rel="tooltip" title="No charge during trial. You will not pay this balance.">
		<small>Your Balance</small>
		<span class="account-balance"></span>
		<sup>+tax</sup>
	</a>
	<a href="#" class="account-state-element pay-as-you-go balance">
		<small>Your Balance</small>
		<span class="account-balance"></span>
		<sup>+tax</sup>
	</a>	
	<a href="#" class="account-state-element day-pass balance">
		<small>Day Pass Till</small>
		<span class="day-pass-expire"></span>
	</a>
	<a href="/day-pass" class="day-pass-btn">Day Pass</a>
	<div class="header-links">
		<div class="search">
			<form method="get" action="/search">
				<input type="hidden" name="searchSubmitted" value="y"
					id="searchSubmitted"> <input type="hidden" name="sortBy"
					value="-startDate" id="sortBy"> <input name="keywords"
					tabindex="1" type="search" class="search-input">
				<button type='submit' class="submit">
					<i class="fas fa-search"></i>
				</button>
			</form>
		</div>
		<ul>
			<li>
				<a class="slide-menu-section" href="javascript:void(0);">
					<i class="fas fa-envelope contact-icon"></i>
				</a>
				<ul class="slide-menu-inner">
					<li><a href="/contact-us">Contact Us</a></li>
					<li><a href="/newstips">Submit a News Tip</a></li>
					<li><a href="/opinion/send_a_letter">Send a Letter to the Editor</a></li>
					<li><a href="/mediakit/#contact-info">Advertising Contact</a></li>
					<li><a href="/biographies">Staff Biographies</a></li>
											<li><a href="#" class="report">Report an Error</a></li>
									</ul>
			</li>
			<li>
				<a class="slide-menu-section" href="javascript:void(0);"><i class="fas fa-user-cog settings-icon"></i></a>
				<ul class="slide-menu-inner">
					<div class="loader">
						<p>
							<img src="//media.brandonsun.com/designimages/jq-lightbox-ico-loading.gif"><br>Finding
							your<br>information
						</p>
					</div>												
					<div class="loggedout">
						<li><a class="fpnewsplatform-login" href="https://fpnewsplatform.winnipegfreepress.com/login/">Log in</a></li> 
						<li><a class="fpnewsplatform-register" href="https://fpnewsplatform.winnipegfreepress.com/register/">Create Account</a></li> 
						<li><a class="type-help">Help</a></li> 
						<li><hr /></li>
						<li><a class="view-type-anchor grid-view" href="javascript:">Grid View</a></li>
						<li><a class="view-type-anchor list-view" href="javascript:">List View</a></li>
						<li><a class="view-type-anchor compact-view" href="javascript:">Compact View</a></li>
						<li><a class="text-size-anchor" href="javascript:">Text Size</a></li>
						<li><a class="translate-anchor" href="javascript:">Translate</a></li>
					</div>
					<div class="loggedin">
						<li><a class="fpnewsplatform-account" href="https://fpnewsplatform.winnipegfreepress.com/account/">My Account</a></li>
						<li class="account-state-element subscriber"><a href="/customer-service" class="click-manage-subscription-button">Manage My Subscription</a></li>
						<li><a class="fpnewsplatform-change-password" href="https://fpnewsplatform.winnipegfreepress.com/change-password/">Change Password</a></li>
						<li><hr /></li>
						<li><a class="view-type-anchor grid-view" href="javascript:">Grid View</a></li> 
						<li><a class="view-type-anchor list-view" href="javascript:">List View</a></li> 
						<li><a class="view-type-anchor compact-view" href="javascript:">Compact View</a></li> 
						<li><a class="text-size-anchor" href="javascript:">Text Size</a></li> 
						<li><a class="translate-anchor" href="javascript:">Translate</a></li> 
						<li><hr /></li> 
						<li><a class="fpnewsplatform-logout" href="https://fpnewsplatform.winnipegfreepress.com/logout/">Log Out</a></li> 
					</div>
				</ul>
			</li>
			<li>
				<a class="type-help"><i class="fas fa-question"></i></a>
			</li>
		</ul>
		<div class="account-help notranslate">
			<div class="loggedout">
				<a class="fpnewsplatform-login" href="https://fpnewsplatform.winnipegfreepress.com/login/">Log in</a> 
				<a class="fpnewsplatform-register" href="https://fpnewsplatform.winnipegfreepress.com/register/">Create Account</a>  
				<a class="fpnewsplatform-subscribe click-subscribe-button" href="/subscribe/">Subscribe</a> 
				<a href="/contact-us/">Contact Us</a> 
			</div> 
			<div class="loggedin">
				<a href="/contact-us/">Contact Us</a>  				
				<a class="fpnewsplatform-subscribe click-subscribe-button" href="/subscribe/">Subscribe</a> 
				<a class="click-manage-subscription-button" href="/customer-service/">Manage Subscription</a> 
				<a class="click-insider" href="/insider/">Insider</a>	 	
			</div>
		</div>
	</div>
</div>
								</div>
								<nav class="notranslate">
										<ul>
		<li>
			<a href="Javascript: void(0);" id="nav-open-btn" class="nav-btn"><i class="fas fa-bars"></i> All Sections</a>
		</li>
		<li>
			<a href="/local">Local</a>
		</li>
		<li>
			<a href="/arts-and-life">Arts &amp; Life</a>
		</li>
		<li>
			<a href="/business">Business</a>
		</li>
		<li>
			<a href="/sports">Sports</a>
		</li>
		<li>
			<a href="//www.theleafnews.com/" target="_blank">Cannabis</a>
		</li>
		<li>
			<a href="/opinion">Opinion</a>
		</li>
		<li>
			<a href="/arts-and-life/life/faith">Faith</a>
		</li>
		<li><a href="https://homes.winnipegfreepress.com/winnipeg-real-estate">Homes</a>
		</li>
		<li><a href="https://autos.winnipegfreepress.com/">Autos</a></li>
		<li><a href="http://marketplace.winnipegfreepress.com">Classifieds</a></li>
		<li><a href="http://flyertown.winnipegfreepress.com?p=wfp&amp;chrome=nohead&amp;locale=en&amp;utm_source=fm&amp;utm_medium=fm_4513&amp;utm_term=title&amp;utm_campaign=wishabi_1_0">Flyers</a></li>
		<li><a href="https://www.winnipegfreepress.com/canada-coupons">Coupons</a></li>
		<li><a href="http://marketplace.winnipegfreepress.com/winnipeg/careers/search">Careers</a></li>
		<li><a href="https://passages.winnipegfreepress.com">Obituaries</a></li>
			</ul>
								</nav>
																																		<div class="breadcrumbs">
														<a href="/" class="entypo-home"></a>																					<i class="entypo-right-open"></i>
											<a href="/sports">Sports</a>
																										<i class="entypo-right-open"></i>
											<a href="/sports/football">Football</a>
																										<i class="entypo-right-open"></i>
																		<a href="/sports/football/bombers">Bomber Report</a>												 																			</div>
															</header>
													</div>
													<div id="fixedHeaderClose" style="clear: both;"></div>
														 																																										</div>
																							</div>
	<div id="wallpaperBackground" class="photoswipe_container" data-pswp-uid="1">
	<div class="text-wrapper">
																																															
			<div class="block">
			
															
				<div class="article-ad">
					<p class="fl">Advertisement</p>
					<p class="fr"><a href="/mediakit/">Advertise With Us</a></p>
					<div id="big_box_top" class="ad-article"></div>
				</div>
				
																
				<div class="article-title">
					<div class="wrap">
																																																																																															<h1>Argonauts QB remains upbeat</h1>
																					<h2>'...The chemistry is fantastic,' even after 0-6 start, pivot says</h2>
																										<p class="byline">
																											<img src="//media.winnipegfreepress.com/images/Sawatzky-Mike2.jpg" class="author-portrait" alt="Mike Sawatzky">																									
																																									By: <a href='https://www.winnipegfreepress.com/biographies/395467431.html'>Mike Sawatzky</a><br>																								
																																Posted: <strong><span>08/1/2019 3:00 AM</span></strong>																<span class="noprint">
																											 | <a href="#have-your-say" class="comment-count">Comments: </a>																	</span>
								
							</p>
						 				 
						 					</div>
				</div>	
			</div>
												
								<script type="text/javascript">var trkcid=513478282;var partnerID=400744; var _hb=1;</script><script type="text/javascript" src="https://www.winnipegfreepress.com/g/g/button/button_1.js"></script>
<ul class="block interactive">
	<li data-network="twitter" class="share st_twitter_custom st-custom-button" st_title=" Argonauts QB remains upbeat - via @winnipegnews">
				<span class="icon-twitter"></span> <span class="share-name">Tweet</span> <span class="count"></span> 
			</li>
	<li data-network="facebook" class="share st_facebook_custom st-custom-button">
			<span class="icon-facebook"></span> <span class="share-name">Post</span> <span class="count"></span> 
		</li>
	<li data-network="reddit" class="share st_reddit_custom st-custom-button">
			<span class="icon-reddit"></span> <span class="share-name">Reddit</span> <span class="count"></span> 
			</li>
	<li data-network="sharethis" class="share st_sharethis_custom st-custom-button">
	
		<span class="icon-share"></span> <span class="share-name">ShareThis</span> <span class="count"></span> 
	</li>
	<li class="print">
		<a class="print" href="javascript:window.print();" title="Print 'Argonauts QB remains upbeat'"><span class="icon-print"></span> <span class="share-name">Print</span></a>
	</li>
	<li data-network="email" class="share st_email_custom st-custom-button">
		<span class="icon-email"></span> <span class="share-name">Email</span> <span class="count"></span> 
	</li>
</ul>

						
															
															
															
												

			
			<!--endclickprintexclude-->
			
														
																<div class="block topphoto ">
					<figure class="photoswipe_slides">
						<a href='https://media.winnipegfreepress.com/images/NEP6253373.jpg'  data-index="1" data-size='2048x1365'><img src="https://media.winnipegfreepress.com/images/NEP6253373.jpg" alt="JOHN WOODS / THE CANADIAN PRESS FILES</p><p>Despite his team&rsquo;s 0-6 start to the season, Argos QB McLeod Bethel-Thompson feels he&rsquo;s leading a good team that needs to play to its potential.</p>"></a>
						<figcaption><p>JOHN WOODS / THE CANADIAN PRESS FILES</p><p>Despite his team&rsquo;s 0-6 start to the season, Argos QB McLeod Bethel-Thompson feels he&rsquo;s leading a good team that needs to play to its potential.</p></figcaption>
					</figure>
				</div>
						
																
								
								
								
								
								
												
												
												<div class="content  ">
																<style>.paidaccess, .nopaymentmethod, .notsubscribed, .trialexpired {display:none;}</style>
<div class="block storycontent cxenseignore">

	<div class="paywallteaser storycontent">	
			<p>TORONTO &mdash; Argos quarterback McLeod Bethel-Thompson has suited up with 13 organizations in nine years as a pro.</p><p>In short, he has some experience with the trials and tribulations of a life in football. But he insists he won&rsquo;t let Toronto&rsquo;s 0-6 start crush his enthusiasm for the game.</p><p>&ldquo;If we were just a bad team, it would be just a bad team,&rdquo; Bethel-Thompson said Wednesday morning at BMO Field. &ldquo;But we&rsquo;re a good team that&rsquo;s performing badly. And you sound like a broken record, and you get sick talking about it over and over again, and now seeing the results.</p><p>&ldquo;The losing part was the hard part, but the chemistry&rsquo;s fantastic. We have everything in this locker room and everything on this team except wins. Coach (Corey) Chamblin has been leading us like nobody could, especially at this time. When it comes, this will be a better story for you guys to write.&rdquo;</p>
					<div class="fade"></div>
			</div>
	<div style="clear: both">	
		
				<div class="notsubscribed storycontent test-a" data-test-name="GetFullStory">
			<p class="one-click-reg-title">Get the full story:</p>
			<div class="one-click-reg-container">
				<form class="one-click-reg" action="javascript:void(0)">
					<p class="error" style="display:none;"></p>
					<label for="email">Email Address:</label>
					<input type="text" name="email">
					<input type="checkbox" name="casl">
										<label for="casl"><small>I agree to the <a href='https://www.winnipegfreepress.com/terms-conditions/'>Terms and Conditions, Cookie and Privacy Policies</a>, and <a href='https://fpnewsplatform.winnipegfreepress.com/casl_consent'>CASL agreement</a>.</small></label>
					<input type="submit" value="Continue Reading">
				</form>
				<p>Already have an account? <a href="https://fpnewsplatform.winnipegfreepress.com/login?fromArticle=1&rurl=https://www.winnipegfreepress.com/sports/football/bombers/argonauts-qb-remains-upbeat-513478282.html">Log in here &raquo;</a></p>
			</div>
		</div>
				<div class="notsubscribed storycontent test-b" data-test-name="KeepReading">
			<p class="one-click-reg-title">Keep reading free:</p>
			<div class="one-click-reg-container">
				<form class="one-click-reg" action="javascript:void(0)">
					<p class="error" style="display:none;"></p>
					<label for="email">Email Address:</label>
					<input type="text" name="email">
					<input type="checkbox" name="casl">
										<label for="casl"><small>I agree to the <a href='https://www.winnipegfreepress.com/terms-conditions/'>Terms and Conditions, Cookie and Privacy Policies</a>, and <a href='https://fpnewsplatform.winnipegfreepress.com/casl_consent'>CASL agreement</a>.</small></label>
					<input type="submit" value="Continue Reading">
				</form>
				<p>Already have an account? <a href="https://fpnewsplatform.winnipegfreepress.com/login?fromArticle=1&rurl=https://www.winnipegfreepress.com/sports/football/bombers/argonauts-qb-remains-upbeat-513478282.html">Log in here &raquo;</a></p>
			</div>
		</div>
				<div class="notsubscribed storycontent test-c">
			<p><strong>Subscribers</strong> Log in below to continue reading,<br> not a subscriber? Create an account to start a 30 day free trial.</p>
			<p><a class="button" href="https://fpnewsplatform.winnipegfreepress.com/login?fromArticle=1&rurl=https://www.winnipegfreepress.com/sports/football/bombers/argonauts-qb-remains-upbeat-513478282.html">Log in</a> <a class="button endofmeter-offer" data-type="test-c" href="https://fpnewsplatform.winnipegfreepress.com/register">Create your account</a></p>
		</div>
		<div class="nopaymentmethod storycontent wfp-endoftrial-teaser">
			<h2>Your free trial has come to an end.</h2>
			<p>We hope you have enjoyed your trial! To continue reading, we recommend our Read Now Pay Later membership. Simply add a form of payment and pay only 27¢ per article.</p>
 			<a class="endoftrial-offer" data-type="promo-rnpl" href="https://fpnewsplatform.winnipegfreepress.com/account/payment"><img src="//media.winnipegfreepress.com/designimages/end-of-trial-offers02.jpg" /></a>
 			<p>For unlimited access to the best local, national, and international news and much more, try an All Access Digital subscription:</p>
			<a class="endoftrial-offer" data-type="promo-subscribe" href="https://fpnewsplatform.winnipegfreepress.com/subscribe-all-access-digital?campaign=trial099"><img src="//media.winnipegfreepress.com/designimages/end-of-trial-offers03.jpg" /></a>
			<p>Thank you for supporting the journalism that our community needs!</p>
		</div>
				<div class="trialexpired storycontent wfp-endoftrial-teaser test-a" data-message="test-a">
			<div class="endoftrial">
				<h2>Your free trial has come to an end.</h2>
				<p>We hope you have enjoyed your trial! To continue reading, we recommend our Read Now Pay Later membership. Simply add a form of payment and pay only 27¢ per article.</p>
				<a class="endoftrial-offer" data-type="promo-rnpl" href="https://fpnewsplatform.winnipegfreepress.com/account/payment"><img src="//media.winnipegfreepress.com/designimages/end-of-trial-offers02.jpg" /></a>
				<p>For unlimited access to the best local, national, and international news and much more, try an All Access Digital subscription:</p>
				<a class="endoftrial-offer" data-type="promo-subscribe" href="https://fpnewsplatform.winnipegfreepress.com/subscribe-all-access-digital?campaign=trial099"><img src="//media.winnipegfreepress.com/designimages/end-of-trial-offers03.jpg" /></a>
				<p>Thank you for supporting the journalism that our community needs!</p>
			</div>
		</div>
				<div class="trialexpired storycontent wfp-endoftrial-teaser test-b" data-message="test-b">
			<h2>We hope you have enjoyed your free trial!</h2>
			<p style="padding: 0;">To continue reading, select a plan below:</p>
			<div class="subscription-grid two-boxes">
				<div class="aad">
					<h4>All Access Digital</h4>
					<p><strong>Introductory pricing*</strong></p>
					<p class="big-price">99<sup>&#162;</sup></p>
					<p><strong>per month</strong></p>
					<ul>
						<li>Unlimited online reading and commenting</li>
						<li>Daily newspaper replica e-Edition</li>
						<li>News Break - our award-winning iOS app</li>
						<li>Exclusive perks &amp; discounts</li>
					</ul>
					<a class="endoftrial-offer button" data-type="promo-subscribe" href="https://fpnewsplatform.winnipegfreepress.com/subscribe-all-access-digital?campaign=trial099">Continue</a>
				</div>
				<div class="rnpl">
					<h4>Read Now Pay Later</h4>
					<p><strong>Pay</strong></p>
					<p class="big-price">27<sup>&#162;</sup></p>
					<p><strong>per article</strong></p>
					<ul>
						<li>Commitment-free</li>
						<li>Cancel anytime</li>
						<li>Only pay for what you read</li>
						<li>Refunds available</li>
					</ul>
					<a class="endoftrial-offer button" data-type="promo-rnpl" href="https://fpnewsplatform.winnipegfreepress.com/account/payment">Continue</a>
				</div>
			</div>
			<p><small>*Introductory pricing schedule for 12 month: $0.99/month plus tax for first 3 months, $5.99/month for months 4 - 6, $10.99/month for months 7 - 9, $13.99/month for months 10 - 12. Standard All Access Digital rate of $16.99/month begins after first year.</small></p>
		</div>
				<div class="trialexpired storycontent wfp-endoftrial-teaser test-c" data-message="test-c">
			<h2>We hope you have enjoyed your free trial!</h2>
			<p style="padding:0;">To continue reading, select a plan below:</p>
			<div class="subscription-grid three-boxes">
				<div class="rnpl">
					<h4>Read Now Pay Later</h4>
					<p><strong>Pay</strong></p>
					<p class="big-price">27<sup>&#162;</sup></p>
					<p><strong>per article</strong></p>
					<ul>
						<li>Commitment-free</li>
						<li>Cancel anytime</li>
						<li>Only pay for what you read</li>
						<li>Refunds available</li>
					</ul>
					<a class="endoftrial-offer button" data-type="promo-rnpl" href="https://fpnewsplatform.winnipegfreepress.com/account/payment">Continue</a>
				</div>
				<div class="aad">
					<h4>All Access Digital</h4>
					<p><strong>Introductory pricing*</strong></p>
					<p class="big-price">99<sup>&#162;</sup></p>
					<p><strong>per month</strong></p>
					<ul>
						<li>Unlimited online reading and commenting</li>
						<li>Daily newspaper replica e-Edition</li>
						<li>News Break - our award-winning iOS app</li>
						<li>Exclusive perks &amp; discounts</li>
					</ul>
					<a class="endoftrial-offer button" data-type="promo-subscribe" href="https://fpnewsplatform.winnipegfreepress.com/subscribe-all-access-digital?campaign=trial099">Continue</a>
				</div>
				<div class="delivery">
					<h4>Mon to Sat Delivery</h4>
					<p><strong>Pay</strong></p>
					<p class="big-price"><sup>$</sup>34.36</p>
					<p><strong>per month</strong></p>
					<ul>
						<li>Includes all benefits of All Access Digital</li>
						<li>6-day delivery of our award-winning newspaper</li>
					</ul>
					 <a class="endoftrial-offer button" data-type="promo-6day" href="https://selfservice.winnipegfreepress.com/cgi-bin/cmo_cmo.sh/custservice/web/addrfind.html?siteid=WFP">Continue</a>
				</div>
			</div>
			<p><small>*Introductory pricing schedule for 12 month: $0.99/month plus tax for first 3 months, $5.99/month for months 4 - 6, $10.99/month for months 7 - 9, $13.99/month for months 10 - 12. Standard All Access Digital rate of $16.99/month begins after first year.</small></p>
		</div>
				<div class="trialexpired storycontent wfp-endoftrial-teaser test-d" data-message="test-d">
			<h2>We hope you have enjoyed your free trial!</h2>
			<p style="padding: 0;">To continue reading, select a plan below:</p>
			<div class="subscription-grid two-boxes">
				<div class="aad">
					<h4>All Access Digital</h4>
					<p><strong>Introductory pricing*</strong></p>
					<p class="big-price">99<sup>&#162;</sup></p>
					<p><strong>per month</strong></p>
					<ul>
						<li>Unlimited online reading and commenting</li>
						<li>Daily newspaper replica e-Edition</li>
						<li>News Break - our award-winning iOS app</li>
						<li>Exclusive perks &amp; discounts</li>
					</ul>
					<a class="endoftrial-offer button" data-type="promo-subscribe" href="https://fpnewsplatform.winnipegfreepress.com/subscribe-all-access-digital?campaign=trial099">Continue</a>
				</div>
				<div class="rnpl">
					<h4>Read Now Pay Later</h4>
					<p><strong>Pay</strong></p>
					<p class="big-price">27<sup>&#162;</sup></p>
					<p><strong>per article</strong></p>
					<ul>
						<li>Commitment-free</li>
						<li>Cancel anytime</li>
						<li>Only pay for what you read</li>
						<li>Refunds available</li>
					</ul>
					<a class="endoftrial-offer button" data-type="promo-rnpl" href="https://fpnewsplatform.winnipegfreepress.com/account/payment">Continue</a>
				</div>
			</div>
			<p><small>*Introductory pricing schedule for 12 month: $0.99/month plus tax for first 3 months, $5.99/month for months 4 - 6, $10.99/month for months 7 - 9, $13.99/month for months 10 - 12. Standard All Access Digital rate of $16.99/month begins after first year.</small></p>
		</div>
				<div class="trialexpired storycontent wfp-endoftrial-teaser test-e" data-message="test-e">
			<h2>We hope you have enjoyed your free trial!</h2>
			<p style="padding: 0;">To continue reading, select a plan below:</p>
			<div class="subscription-grid two-boxes">
				<div class="rnpl">
					<h4>Read Now Pay Later</h4>
					<p><strong>Pay</strong></p>
					<p class="big-price">27<sup>&#162;</sup></p>
					<p><strong>per article</strong></p>
					<ul>
						<li>Commitment-free</li>
						<li>Cancel anytime</li>
						<li>Only pay for what you read</li>
						<li>Refunds available</li>
					</ul>
					<a class="endoftrial-offer button" data-type="promo-rnpl" href="https://fpnewsplatform.winnipegfreepress.com/account/payment">Continue</a>
				</div>
				<div class="aad">
					<h4>All Access Digital</h4>
					<p><strong>Introductory pricing*</strong></p>
					<p class="big-price">99<sup>&#162;</sup></p>
					<p><strong>per month</strong></p>
					<ul>
						<li>Unlimited online reading and commenting</li>
						<li>Daily newspaper replica e-Edition</li>
						<li>News Break - our award-winning iOS app</li>
						<li>Exclusive perks &amp; discounts</li>
					</ul>
					<a class="endoftrial-offer button" data-type="promo-subscribe" href="https://fpnewsplatform.winnipegfreepress.com/subscribe-all-access-digital?campaign=trial099">Continue</a>
				</div>
			</div>
			<p><small>*Introductory pricing schedule for 12 month: $0.99/month plus tax for first 3 months, $5.99/month for months 4 - 6, $10.99/month for months 7 - 9, $13.99/month for months 10 - 12. Standard All Access Digital rate of $16.99/month begins after first year.</small></p>
		</div>
               <div class="trialexpired storycontent bsn-endoftrial-teaser">
                    <div class="nopaymentmethod storycontent bsn-endoftrial-teaser" style="display:none;">
                          <div class="endoftrial">
			        <h2>Your free trial has come to an end.</h2>
			        <p>We hope you have enjoyed your trial! To continue reading, we recommend our Read Now Pay Later membership. Simply add a form of payment and pay only 27¢ per article.</p>
 			        <a class="endoftrial-offer" data-type="promo-rnpl" href="https://fpnewsplatform.winnipegfreepress.com/account/payment"><img src="//media.winnipegfreepress.com/designimages/bs-end-of-trial-offers02.jpg" /></a>
 			        <p>For unlimited access to the best local, national, and international news and much more, try an All Access Digital subscription:</p>
			        <a class="endoftrial-offer" data-type="promo-subscribe" href="/subscribe"><img src="//media.winnipegfreepress.com/designimages/bs-end-of-trial-offers01.jpg" /></a>
			        <p>Thank you for supporting the journalism that our community needs!</p>
                          </div>
		    </div>
               </div>
	</div>
</div>



										<div class="paidaccess block storycontent ">
											<!-- cxenseparse_start -->
																																																																																																																																																																															<p>TORONTO &mdash; Argos quarterback McLeod Bethel-Thompson has suited up with 13 organizations in nine years as a pro.			</p>																																					<p>In short, he has some experience with the trials and tribulations of a life in football. But he insists he won&rsquo;t let Toronto&rsquo;s 0-6 start crush his enthusiasm for the game.			</p>						<div class="mobile-inarticle-container" style="text-align:center;">			<div id="mobile-inarticle-banner" class="ad-mobile-inarticle-banner"></div>		</div>											<!-- image orientation is: landscape -->
																																		<p>&quot;If we were just a bad team, it would be just a bad team,&quot; Bethel-Thompson said Wednesday morning at BMO Field. &quot;But we&rsquo;re a good team that&rsquo;s performing badly. And you sound like a broken record, and you get sick talking about it over and over again, and now seeing the results.			</p>																																														<p>&quot;The losing part was the hard part, but the chemistry&rsquo;s fantastic. We have everything in this locker room and everything on this team except wins. Coach (Corey) Chamblin has been leading us like nobody could, especially at this time. When it comes, this will be a better story for you guys to write.&quot;			</p>																																					<p>Toronto is trying to avoid an 0-7 start for the first time since 1981, when it started 0-9 on the way to a 2-14 finish.			</p>																																					<p>Star wide receiver Derel Walker said the turnover blame shouldn&rsquo;t rest belong exclusively with Bethel-Thompson, who has thrown nine interceptions in three starts.			</p>																																					<p>&quot;Turnovers, regardless, have been killing (us),&quot; Walker said. &quot;You can&rsquo;t just say interceptions. We&rsquo;ve been turning the ball over, fumbling, tipped passes. Once we limit that, this team will be very special. We have a lot of talent around this team and we still believe.&quot;			</p>																																														<p><strong>LINEUP SHUFFLE:</strong> A leg injury suffered Monday by third-year halfback Brandon Alexander means a personnel change for Winnipeg in the secondary. The club listed Chris Humes as his replacement, while also adding defensive back Mike Jones from the practice roster as a replacement for punt returner Kenny Walker.			</p>														<!-- image orientation is: landscape -->
												<figure class="inline photoswipe_slides full">						<a href='https://media.winnipegfreepress.com/images/NEP6253395.jpg'  data-index='2' data-size='2048x1466'>							<img src="https://media.winnipegfreepress.com/images/NEP6253395.jpg" alt="JEFF MCINTOSH / THE CANADIAN PRESS FILES</p><p>Toronto&rsquo;s Derel Walker is third among the league&rsquo;s receivers with 483 yards on 28 catches.</p>">						</a>						<figcaption><p>JEFF MCINTOSH / THE CANADIAN PRESS FILES</p><p>Toronto&rsquo;s Derel Walker is third among the league&rsquo;s receivers with 483 yards on 28 catches.</p></figcaption>					</figure>																																											<p>Wide receiver Darvin Adams&rsquo; lower-body ailment will keep him out, replaced by Chris Matthews, while strongside linebacker Anthony Gaitor (upper body) and wide receiver Drew Wolitarsky (lower body) got the green light after leaving Friday&rsquo;s game in Hamilton.			</p>																																					<p><strong>TOP THREAT:</strong> Wide receiver Walker was one of the most sought-after free agents in the off-season before signing a one-year deal with Toronto worth about $285,000. The Blue Bombers were among his most ardent suitors, reportedly offering the two-time CFL all-star a salary of $275,000.			</p>																																					<p>Walker insists he doesn&rsquo;t regret his choice, even with the Argos off to an 0-6 start.			</p>																																														<p>&quot;Who could imagine starting the season this way, but hey, sometimes you&rsquo;ve got to go through things to get somewhere you haven&rsquo;t been in quite a while,&quot; he said.			</p>																																					<p>Winnipeg was a strong contender.			</p>																																					<p>&quot;They were right there in the running,&quot; Walker said. &quot;Things just obviously played out this way. They&rsquo;ve been playing very well this year and we haven&rsquo;t. We&rsquo;re going in tomorrow with a lot of confidence and a lot of positive positivity.&quot;			</p>																																					<p>Toronto&rsquo;s struggles haven&rsquo;t diminished Walker&rsquo;s numbers.			</p>																																												<p>He has 21 catches for 344 yards over his past three games, including two touchdowns and five receptions on second-down conversions, and now sits third overall among the league&rsquo;s pass-catchers with 483 yards on 28 catches.			</p>																																					<p><strong>NOTEWORTHY</strong>: Winnipeg corner Winston Rose was named a CFL performer of the month after raising his league-leading interception total to five. The 25-year-old has a pick in his past four games, equalling a mark accomplished only twice (Edmonton&rsquo;s Weldon Brown in 2011 and Chris Thompson in 2010) since 1994... Ex-Blue Bombers linebacker Ian Wild will come off Toronto&rsquo;s six-game injured list early to play tonight... Toronto has employed the most starters this year with 39. Winnipeg has used a league-low of 27 over six games.			</p>																																					<p>mike.sawatzky@freepress.mb.ca			</p>																																					<p>Twitter: @sawa14			</p>																																																																															
																									
																																				
																																	<div class="article-bio">
																	<div>
										<img src="https://media.winnipegfreepress.com/images/Sawatzky-Mike2.jpg" class="author-portrait" alt="Mike Sawatzky">									</div>
																<div>
									<p><strong>Mike Sawatzky</strong><br /><em>Sports Reporter</em></p>
																			<p>Mike has been working on the Free Press sports desk since 2003.</p>
																		<p><a href="https://www.winnipegfreepress.com/biographies/395467431.html">Read full biography</a></p>
								</div>
							</div>
																						<!-- cxenseparse_end -->
									</div>
			</div>
								
															<div class="side-bar paidaccess">
				<!-- cxenseparse_start -->
																														<!-- cxenseparse_end -->
																					<div class="related-items cxenseignore">
		<h3>Related Items</h3>
									<h4 class="related">Articles</h4>
				<div class="content">
					<ul>
																																																																																																																													<li>
																			<img src="https://media.winnipegfreepress.com/images/120*90/190712BombersvsArgos017.jpg" alt="Blowout? Don't bet on it">																		<!-- origPubDate Thu Aug 01 01:00:00 PDT 2019 item.startDate Wed Jul 31 17:00:00 PDT 2019 updateDate Thu Aug 01 01:00:00 PDT 2019 updateDateString $updateDateString -->
																																																																								<span style="overflow: hidden; display: block;">
																			<a href="https://www.winnipegfreepress.com/sports/blowout-dont-bet-on-it-513460742.html"> Jul 31, 2019: Bombers expecting an improved, but still winless, Argonauts Thursday</a>
																												<span class="author">Mike Sawatzky</span>
																		</span>
								</li>										
																		</ul>
				</div>
						</div>
																																																						</div>																		<div id="skyscraper_shaft" class="article-ad cxenseignore">				<div id="skyscraper_container">
					<p class="fl">Advertisement</p>
					<p class="fr"><a href="/mediakit/">Advertise With Us</a></p>						
					<div id="skyscraper_top" class="ad-skyscraper"></div>
				</div>
			</div>																							
																																																																	<ul class="paidaccess story-buttons">
							<li><a href="#" class="button report">Report Error</a></li>
				<li><a href="/newstips" class="button submit-tip">Submit a Tip</a></li>
				<li><a href="Javascript: void(0);" class="account-state-element trial button refund inactive" title="No charge during trial">Refund</a><a href="Javascript: void(0);" class="inactive account-state-element pay-as-you-go button refund">Refund</a></li>
						</ul>
										<div id="comments" class="paidaccess comments">


		<span id="have-your-say">
			<style>
			.comments {margin: 0; }
			#comments_activation {padding: 1em;}
			#have-your-say { position: relative; top: -200px; display: block;}
			#have-your-say:target ~ #comments_activation { animation: pulse 2s ease-in-out 1;}
			@keyframes pulse {
			  0%, 100% {
				background-color: #fff;
			  }
			  50% {
				background-color: #ddd;
			  }
			}
			</style>
		</span>
		<div class="loggedout">
			<p class="small">
				You can comment on most stories on The Winnipeg Free Press website. You can also agree or disagree with other comments. 
				All you need to do is be a Winnipeg Free Press print or digital subscriber to join the conversation and give your feedback.
			</p>
		</div>
		<div id="comments_activation">
			<h4>Have Your Say</h4>
							<button>Display <span id="secondCommentCount513478282"></span> comments</button>
						
		</div>
		<div class="loggedout">
			<div class="comments_subscribe">
				<h4>Have Your Say</h4>
				<p>Comments are open to The Winnipeg Free Press print or digital subscribers only. <a href="/local/keeping-the-e-party-going-without-the-party-crashers-208927251.html" class="small">why?</a></p>
				<a class="login-button button type-login" href="https://fpnewsplatform.winnipegfreepress.com/login/?rurl=http://www.winnipegfreepress.com/sports/football/bombers/argonauts-qb-remains-upbeat-513478282.html">Log in</a>
				<a class="subscribe-button button type-register" href="/subscribe" onclick="_gaq.push(['_trackEvent', 'wfpCommentsSubscribe-click', 'loggedout', 'http://www.winnipegfreepress.com/sports/football/bombers/argonauts-qb-remains-upbeat-513478282.html']);">Subscribe</a>
			</div>
		</div>
		<div class="loggedin">
			<div class="isNotSbscrbr">
				<div class="comments_subscribe">
					<h4>Have Your Say</h4>
					<p>Comments are open to The Winnipeg Free Press Subscribers only. <a href="/local/keeping-the-e-party-going-without-the-party-crashers-208927251.html" class="small">why?</a></p>
					<a class="subscribe-button button type-subscribe" href="/subscribe" onclick="_gaq.push(['_trackEvent', 'wfpCommentsSubscribe-click', 'isNotSubscriber', 'http://www.winnipegfreepress.com/sports/football/bombers/argonauts-qb-remains-upbeat-513478282.html']);">Subscribe</a>
				</div>
			</div>
		</div>
		<div id="comments_container"></div>	
		<p id="comments_disclaimer"><small>By submitting your comment, you agree to abide by our <a href="https://www.winnipegfreepress.com/comments-termsandconditions.html">Community Standards and Moderation Policy</a>. These guidelines were revised effective February 27, 2019. Have a question about our comment forum? Check our <a href="/comments-termsandconditions.html#commentsfaq">frequently asked questions</a>.</small></p>
	</div>
														<div id="bdnsun-bottom-article-banner-container" class="tile six-col ad v4_tile_ad_banner" size="3">
				<div class="tile-padding">
					<div class="tile-content">
						<p class="fl">Advertisement</p>
						<p class="fr"><a href="/mediakit/">Advertise With Us</a></p>
						<div class="ad-banner" id="bdnsun-bottom-article-banner"></div>
					</div>
				</div>
			</div>
										<div class="pswp" tabindex="-1" role="dialog" aria-hidden="true">
    <div class="pswp__bg"></div>
    <div class="pswp__scroll-wrap">
        <div class="pswp__container">
            <div class="pswp__item"></div>
            <div class="pswp__item"></div>
            <div class="pswp__item"></div>
        </div>
        <div class="pswp__ui pswp__ui--hidden">
            <div class="pswp__top-bar">
                <div class="pswp__counter"></div>
                <button class="pswp__button pswp__button--close" title="Close (Esc)"></button>
                <button class="pswp__button pswp__button--share" title="Share"></button>
                <button class="pswp__button pswp__button--fs" title="Toggle fullscreen"></button>
                <button class="pswp__button pswp__button--zoom" title="Zoom in/out"></button>
                <div class="pswp__preloader">
                    <div class="pswp__preloader__icn">
                      <div class="pswp__preloader__cut">
                        <div class="pswp__preloader__donut"></div>
                      </div>
                    </div>
                </div>
            </div>
            <div class="pswp__share-modal pswp__share-modal--hidden pswp__single-tap">
                <div class="pswp__share-tooltip"></div> 
            </div>
            <button class="pswp__button pswp__button--arrow--left" title="Previous (arrow left)">
            </button>
            <button class="pswp__button pswp__button--arrow--right" title="Next (arrow right)">
            </button>
            <div class="pswp__caption">
                <div class="pswp__caption__center"></div>
            </div>
        </div>
    </div>
</div>
<script id="id_photoswipe_script" type="text/javascript">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</script>


	</div>
</div>
	<div id="top-link">
	<a href="#inner-wrap" class="cd-top"><i class="fas fa-angle-up"></i>Top</a>
</div>
				
	

<script src="https://www.winnipegfreepress.com/includes/51cb3fe4ea995f656b7e6f18e4fabc47/common.min.js"></script>

<script src="https://scdn.cxense.com/cx.js" type="text/javascript" async="async"></script>
<script src="https://scdn.cxense.com/cx.cce.js"></script>
<script type="text/javascript">
	var cX = cX || {}; cX.callQueue = cX.callQueue || [];
</script>		


<script src="https://www.winnipegfreepress.com/includes/4c751e0b483dc09e90ec0937f81f1925/xdomain.min.js" slave="https://fpnewsplatform.winnipegfreepress.com/portal/x/https"></script>	
	

	 		<script src="https://www.winnipegfreepress.com/includes/1e1a6f8f10ea17568a8cf8710f53d1f1/v6_script_fp.min.js"></script>
		<script src="https://www.winnipegfreepress.com/includes/27c7166edb1946f5f9ed6d33525e590f/v6_script_lib.min.js"></script>
					<script src="https://www.winnipegfreepress.com/includes/641d183b492e414298438d4a69229b75/v6_script_lib_article.min.js"></script>
				<script src="https://www.winnipegfreepress.com/includes/dae4e6ee3bb733945824ce0147edbd9b/v6_handlebars.js"></script>
	 

<script>
	var maintenanceMode = false;
	var accountServerUrl = "https://fpnewsplatform.winnipegfreepress.com";
	var section = "/sports/football/bombers";		
	var sectionDisplayName = "Bomber Report";
		var isJumboPage = false;
			var isEditionPage = false;
		var isLandingPage = false;
	var isMultiSectionPage = false;
	var isArticlePage = true;
	var isGeneralPage = false;
	var isCustomPage = false;
	var cxenseSiteID = "9222350621649330874";
	var currentTime = "2019-08-02T07:16:35";
	var currentTimezone = "-0700";
	var publicationName = "Winnipeg Free Press";
	var dfpData = {"channels":["sports","football","bombers"],"imp":"bombers"};
	var environment = "";
			var mainContentArticle = {"full_image_width":1000,"small_image":"https://media.winnipegfreepress.com/images/390*260/NEP6253373.jpg","full_image_height":667,"section":"Bomber Report","small_image_dimensions":"390x260","source":"wfp-circle","title":"Argonauts QB remains upbeat","related_items":[],"path":"/sports/football/bombers","word_count":599,"short_title":"","image_height":432,"content_type":"WFP Story","media_type":"bombers","image_caption":"JOHN WOODS / THE CANADIAN PRESS FILES<\/p><p>Despite his team&rsquo;s 0-6 start to the season, Argos QB McLeod Bethel-Thompson feels he&rsquo;s leading a good team that needs to play to its potential.<\/p>","publish_time":"2019-08-01T08:00:00.000Z","image_credit":"","image_dimensions":"648x432","our_rating":"","id":513478282,"last_modified":"2019-08-01T05:47:53.000Z","image_type":"normal","image":"https://media.winnipegfreepress.com/images/648*432/NEP6253373.jpg","last_updated":"2019-08-01T08:00:00.000Z","sub_title":"'...The chemistry is fantastic,' even after 0-6 start, pivot says","cost":27,"allow_comments":"comments","author":"Mike Sawatzky","full_image_dimensions":"1000x667","image_width":648,"image_title":"NEP6253373","full_image":"https://media.winnipegfreepress.com/images/1000*666/NEP6253373.jpg","url":"https://www.winnipegfreepress.com/sports/football/bombers/argonauts-qb-remains-upbeat-513478282.html","small_image_width":390,"small_image_height":260,"teaser":"TORONTO &mdash; Argos quarterback McLeod Bethel-Thompson has suited up with 13 organizations in nine years as a pro. | In short, he has some experience with the trials and tribulations of a life in football. But he insists he won&rsquo;t let Toronto&rsquo;s 0-6 start crush his enthusiasm for the game. | &ldquo;If we were just a bad team, it would be just a bad team,&rdquo; Bethel-Thompson said Wednesday morning at BMO Field. &ldquo;But we&rsquo;re a good team that&rsquo;s performing badly. And you sound like a broken record, and you get sick talking about it over and over again, and now seeing the results. | &ldquo;The losing part was the hard part, but the chemistry&rsquo;s fantastic. We have everything in this locker room and everything on this team except wins. Coach (Corey) Chamblin has been leading us like nobody could, especially at this time. When it comes, this will be a better story for you guys to write.&rdquo;","dimensions":"648x432"};
		
			var isColumnistPage = false;
	
			var forceRefresh = 1;
</script>
<div id="google_translate_element" style="display:none;"></div><script type="text/javascript">
function googleTranslateElementInit() {			
	new google.translate.TranslateElement({pageLanguage: 'en', layout: google.translate.TranslateElement.InlineLayout.HORIZONTAL, gaTrack: true, gaId: 'UA-350959-63'}, 'google_translate_element');
}
</script><script type="text/javascript" src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit"></script>

	<script src="https://www.winnipegfreepress.com/includes/8726e4afe1b7b80a6122628671959a8e/main.min.js"></script>
		
	<script type="text/javascript" src="//www.googleadservices.com/pagead/conversion.js">
	</script>
	<noscript>
	<div style="display:inline;">
		<img height="1" width="1" style="border-style:none;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/1044439282/?value=0&amp;guid=ON&amp;script=0"/>
	</div>
	</noscript>
	
<script>
$(function() {
	$('.clickOpen').click(function(){
		$(this).hide();
		$(this).next().removeClass("mobile-hide");
	});
	
	var JWpaidAccessCheck = function(){
		if($(".paidaccess").css("display") == "block"){
			if($("iframe[src*='jwplatform']").length && navigator.userAgent.indexOf("irefox") > -1){
				$("iframe[src*='jwplatform']").each(function(i){
					var src = $(this).attr("src");
					$(this).attr("src",src);
				});
			}
			clearInterval(JWverifyPaidAccess);
		}
	}
	var JWverifyPaidAccess = setInterval(JWpaidAccessCheck,500);
	
});
</script>
